Tutorials

Frequently Asked Questions

How do I install the software?

  1. Open the installer executable, or double-click on the shortcut to it.
  2. If you are asked about it, allow changes to be made to your computer.
  3. PixProcessing setup will pop up. Read carefully the instructions, then proceed to next step by clicking Next.
  4. In order to proceed, click I Agree.
  5. Specify the directory where the program and its files will be stored.
  6. Please, wait until the installation procedure is completed. The green progress bar represents the process. A shortcut will be created on your desktop that will launch the application.
  7. Click Finish to complete the installation. If you leave Run PixProcessing checked, the application will start automatically.
  • You can use the demo version for an unlimited period without registering it.
  • The demo installer installs a version that has limitations. The demo version allows processing up to 100 photos and does not allow exporting.

How do I register my application copy?

After installation PixProcessing will run in trial mode for 60 days. At any time you can register the application.
To register it send email to register@pixprocessing.com
The email should contain such information:

  1. Hardware ID, which is taken from Help->About window
  2. User Name
  3. Company Name

You will receive an email containing License Key. Copy data into Help->About window corresponding lines and click Ok.

What are minimum system requirements for PixProcessing?

Minimum hardware and software requirements:

  • Windows 7, 8, 10, Server 2008, Server 2012, 64 bits.
  • Any CPU (Intel i5/ i7/ Xeon recommended).
  • Integrated graphic card Intel HD 4000 and above.
  • Small and medium projects – under 500 photos:
    • 8 GB RAM,
    • 20 GB HDD Free space.
  • Large projects – over 500 photos:
    • 16 GB RAM,
    • 40 GB HDD Free space.

What are recommended system requirements for PixProcessing?

Recommended hardware and software requirements:

  • Windows 7, 8, 10, Server 2008, Server 2012, 64 bits.
  • Any CPU (Intel i5/ i7/ Xeon recommended).
  • Integrated graphic card Intel HD 4000 and above.
  • Hard disk: SSD.
  • Small and medium projects – under 500 photos:
    • 16 GB RAM,
    • 40 GB SSD Free space.
  • Large projects – over 500 photos:
    • 32 GB RAM,
    • 60 GB SSD Free space.

How do I install the software?

  1. Open the installer executable, or double-click on the shortcut to it.
  2. If you are asked about it, allow changes to be made to your computer.
  3. PixProcessing setup will pop up. Read carefully the instructions, then proceed to next step by clicking Next.
  4. In order to proceed, click I Agree.
  5. Specify the directory where the program and its files will be stored.
  6. Please, wait until the installation procedure is completed. The green progress bar represents the process. A shortcut will be created on your desktop that will launch the application.
  7. Click Finish to complete the installation. If you leave Run PixProcessing checked, the application will start automatically.
  • You can use the demo version for an unlimited period without registering it.
  • The demo installer installs a version that has limitations. The demo version allows processing up to 100 photos and does not allow exporting.

How do I register my application copy?

After installation PixProcessing will run in trial mode for 60 days. At any time you can register the application.
To register it send email to register@pixprocessing.com
The email should contain such information:

  1. Hardware ID, which is taken from Help->About window
  2. User Name
  3. Company Name

You will receive an email containing License Key. Copy data into Help->About window corresponding lines and click Ok.

What are minimum system requirements for PixProcessing?

Minimum hardware and software requirements:

  • Windows 7, 8, 10, Server 2008, Server 2012, 64 bits.
  • Any CPU (Intel i5/ i7/ Xeon recommended).
  • Integrated graphic card Intel HD 4000 and above.
  • Small and medium projects – under 500 photos:
    • 8 GB RAM,
    • 20 GB HDD Free space.
  • Large projects – over 500 photos:
    • 16 GB RAM,
    • 40 GB HDD Free space.

What are recommended system requirements for PixProcessing?

Recommended hardware and software requirements:

  • Windows 7, 8, 10, Server 2008, Server 2012, 64 bits.
  • Any CPU (Intel i5/ i7/ Xeon recommended).
  • Integrated graphic card Intel HD 4000 and above.
  • Hard disk: SSD.
  • Small and medium projects – under 500 photos:
    • 16 GB RAM,
    • 40 GB SSD Free space.
  • Large projects – over 500 photos:
    • 32 GB RAM,
    • 60 GB SSD Free space.

Where can I change the parameters of camera and lenses?

To change the camera and lenses parameters or manage the set of photos, click Photos manager on the toolbar and select the preferred values or enter the new ones. In most cases, the software detects the parameters automatically.

What information does the Properties Panel display?

Properties Panel contains the main information of the images – the name of the photo, the date of capturing the image, the amount of features for matching detected by the software, the amount of matches detected during the reconstruction process, as well as the coordinates specific to the definite photo at the moment of capturing the image.

It contains the main information of the project step – project name, type and amount of photos used, amount of photos which are georeferenced, internal coordinate system used for the project, camera and lenses parameters.

What photo's information can be seen in the Photos Manager window?

The selected photos and the main georeferencing information of the images, i.e. latitude, longitude and altitude are displayed. Also, the information about the currently used georeferencing system is automatically detected according to the GPS data provided by the camera.

How do I tell the executed project steps from the non-executed yet?

The completed steps are marked with the filled square on the Layer panel, and the non-executed steps are signed with the empty square.

What does the blue pyramid-shaped object on the 3D model mean?

The blue-contoured pyramid-shaped objects represent all the images included in the reconstruction. Each of them represents a single camera, i.e. the angle of the camera at the moment of capturing the image. If not selected otherwise, all the objects are represented in blue colour. If only one image is selected from the list, the camera (pyramid-shaped object) is presented in distinction by yellow colour.

Why are the selected photos marked with the red sign?

After the first downloading, all the photos are marked with the red sign. It shows that the photos haven‘t been used in the reconstruction yet. The sign disappears when the photos are processed.

Why are some of the photos still marked with the red sign even after processing?

If any photos on the list are still marked with the red sign after the reconstruction of the first layer, it means that the photo was a mismatch to the whole set  and the software did not detect enough matching keypoints with the majority of imagery. The mismatching photo is omitted in order not to infer any distortions in the reconstruction of the project.

How many photos do I need to create a project?

To proceed with the photo reconstruction, you will need to import at least 3 photos.

Can I remove the incompatible or odd photos from the project?

Using the photos manager, you can add and/or remove the selected photos from the project.

How are all the layers loaded when opening an existing project?

All the layers will be restored/loaded separately step by step when the project is opened next time.

How does the number of photos affect the speed of reconstruction process?

The bigger amount of photos is imported, the longer the process of reconstruction will be. Bigger number of images assure that the software detects more matches and reconstruction of the object will be of higher quality and detail.

How do I execute the 3D model reconstruction?

To reconstruct a  3D model, follow these instructions.

What are the ways of the addition of GCP?

Ground control points can be added:

  • either manually inserting the parameters obtained with high accuracy GPS device,
  • or marking the spots on the reconstructed 3D model and gaining the GPS data provided by the maps providers.

The manual insertion of GPS data about the definite spots on the imagery ensures extremely high accuracy. To obtain that type of coordinate parameters, professional GPS devices are used to complement the data acquired with the camera’s GPS.

IMPORTANT: Most of the cameras are equipped with the consumer-grade GPS devices which allow low or mediocre accuracy. The global shift has the greatest impact on the accuracy of obtained coordinate data. Due to disturbed propagation in the ionosphere and the conditions of the atmosphere, the error of about 5 to 20 metres occurs. Therefore, it is advised to use additional high accuracy GPS device to ensure lesser error and more accurate measurements.

How to add ground control points manually?

Manual insertion of GCP:

1. Open an existing project or create a new one. As soon as photos are loaded, the Layers Panel displays the list of project steps. Right-click the Ground Control Points option on the panel to insert the ground control points. The dialogue window appears. Select GCP Manager option.

2. GCP manager dialogue window opens. The option allows selecting the preferred coordinate system and the addition of multiple GCPs as well as removal of the odd ones. ‘World Geodetic System 1984, (EPSG: 4326)’ is set by default but another system can be selected according to the need.

3. NOTE: To change the coordinate system, click More and the Coordinate System dialogue window opens. Select the desired coordinate system from the given list.

4. To proceed, click Add GCP and insert the GCP data manually, i.e. fill in the longitude, the latitude and the elevation measurements obtained with GPS device. When finished, click OK.

5. The Add Ground Control Point dialogue window opens for manual adjustments of selected target points on the imagery. The manually inserted parameters are displayed and the list of photos is shown. Enter the photos for manual adjustments.

6. To ensure accuracy, zoom the image using the tool in the right bottom corner of the window or use the scroll wheel on the mouse.

7. The ground control point is defined as a yellow circle with the target cross in the centre. It can be moved manually with the left-click of the mouse.

8. After checking the GCPs on multiple images for accuracy, click OK button to proceed. The GCP is named ‘GCP1’ by default, but the name can be changed if necessary.

NOTE: At least 2 projections should be marked to form a GCP, otherwise the software is unable to form the definite point and the reminder dialogue window appears.

9. OPTIONAL: To see the projections of definite GCP on the images, double click the GCP (the preferred one) in the GCP manager window and again Edit Ground Control Point dialogue window appears. It allows to manage the GCP on each image and adjust the point on all the matching images simultaneously.

10. When finished, the main window displays all the projections on the map. If not selected otherwise, all the GCPs are denoted as blue circles with the target cross. The selected GCP can be reviewed by single left-click on the Layers Panel. It is projected as a yellow circle and the parameters of the definite GCP are shown in the Properties Panel where the coordinates and projections are displayed.

11. GCPs can be added or removed from the project at any stage according to the need. To edit or remove a GCP, right-click the GCP on the Layers Panel and the dialogue window appears. If clicked Remove GCP, the GCP is instantly removed from the project. For editing the GCP, see section 9.

12. The created GCPs are saved automatically on the exit by clicking OK button on the closing dialogue window to confirm.

How to mark the ground control points on a 3D model?

Marking the GCP on the reconstructed 3D model:

Marking the ground control points on the ready-reconstructed model allows calculations and measurements of volume, height and perimeter, but the accuracy is lesser. To obtain high accuracy calculations, please perform the operation of the manual insertion of GCPs.

1. To start the insertion, right-click the Ground Control Points option on the Layers Panel and click Add GCP.

2. The marker is depicted as a red dot on the point of the arrow. Click the desired spot for creating a GCP on the layer. The Ground Control Point dialogue window appears, displaying the coordinate parameters and the elevation height of the marked GCP. The newly created GCP is reprojected on the map as a blue circle with the target cross. It is automatically named ‘GCPn’ (‘n’ represents any following number in a row of already existing GCPs) by default. Click OK to continue.

3. The dialogue window Add Ground Control Point opens. The parameters (name, projections and projection error) and the location of the point (definite coordinates) of the GCP are displayed. The list of images is shown on the left. The photos which contain a GCP are marked with the target sign. Whereas the images which do not contain any visual information considering the GCP, are enlisted but unmarked as the ‘inactive’ ones.

4. In case there is a need to infer manual adjustments, audit the corresponding images and replace the target point if necessary. Then click Adjust to align the point on all the imagery. Before the adjustment is made, the images which had manual corrections are marked as manually adjusted, but the notice manual disappears as soon as the adjustment is made.

5. When finished, click OK. The GCP is depicted as a blue point on the 3D model. The created GCP is saved automatically on the exit by clicking OK button on the closing dialogue window to confirm.

How often do I have to save the project during the work?

The project can be saved at any stage of reconstruction and as many times as needed to prevent the loss of data in case additional layers have been reconstructed. It is noteworthy that all the progress and changes are saved on the exit by confirming Save option.

Can I pause or cancel the reconstruction?

The reconstruction can be paused and resumed at any time. It can also be cancelled but the progress does not stop immediately as the process has to be closed safely, so it takes a short while to cancel the reconstruction.

Can I generate multiple dense point clouds with different parameters?

Generating the dense point cloud repeatedly, i.e. for the second time and further on, the software allows to adjust the mentioned value according to the need. The same project can contain as many dense point clouds as needed and each will have definite parameters stated by the user. Each time the further reconstruction is made, there is a possibility to select the handiest and most convenient dense point cloud provided from the list on the Layers panel.

How do the unrelated photos in the selected set affect the reconstruction?

In case some unrelated images occur to be imported or the image offers no matches with the majority of the imagery. The software automatically detects mismatch and excludes from the project, i.e. leaves the image unused in order not to infer distortions in the whole project work.

How does the value of the GSD impact the reconstruction quality?

The bigger value of the GSD is selected, the less accurate measurements and calculations are acquired.

What is the minimum GSD value?

The minimum GSD value depends on the user’s PC resources. The software automatically states the minimum value according to the PC memory and the graphics card memory on the definite computer. Thus, the value differs. To get the smaller GSD value for more accuracy, it is advisable to get memory extension.

How much time does the reconstruction take?

The estimated time of the processing the photos depends on the amount of the chosen photos and the estimated quality of the reconstruction.

What parameters does the Neighbour Radius defines?

The larger radius can be used for more severe surface smoothing. The too big radius can cause the elimination of fine important details.

The Neighbour Radius defines the size of the square cell neighbourhood window which sides are calculated/stated according to the formula NeighbourRadius * 2 + 1. The cell’s value is determined by the mean value of the cells situated in the neighbourhood.

What file formats can I use for export and import?

Pixprocessing supports various import and export file formats.

NOTE: Demo version is not granted with export options. Only the Standard version allows exporting.

DXF LAS LAZ PLY STL XYZ PXG CSV TXT SHP
IMPORT
Point Cloud + + + + + +
Meshes + + +
Flight Tracks + + +
Ground Control Points + +
Points + + + + + +
Lines + + +
Surfaces + + +
EXPORT
Point Cloud + + + + + + +
Surface Mesh + + +
Texture Mesh + +
Flight Tracks +
Ground Control Points +
Points + + + + + +
Lines + + +
Surfaces + + +

Digital Elevation Maps (DEM) and Orthophotos files have .tiff extension and they can be found directly in the User > Documents > Pixprocessing projects > Reconstruction project name folder which contains Orthophoto and Digital Elevation Map folders.

What is the DEM/DSM?

Digital elevation map is a vector based irregular network representing the Digital Surface Model (DSM) including the buildings and other on-ground objects

Is the DEM/DSM customizable?

The height map of the depicted object is coloured in red and black by default. The colours can be changed according to the user’s preference. To change the colours, please go to Tools > Options > DEM/Orthophoto section and select the preferred colours.

How do I navigate the 3D model?

From the first layer of reconstruction and further on, the view of the reconstructed model can be easily navigated:
  • left-click the mouse for rotation in all possible directions;
  • re-center the object or change its position in the 3D view window;
  • right-click and drag the object;
  • to zoom the object, use the scroll-wheel on the mouse.

How do I enable/disable the sound effect?

The sound can be disabled according to the user’s needs. To disable/enable the sound, go to Tools> Options> Play Sound when Operation Finished to tick/untick the option.

What options of reconstruction quality can I select?

The quality is set according to the preferable speed and accuracy of the project step, available either high, medium or low.

What do I do if Pixprocessing does not start?

Check Pixprocessing properties: the compatibility mode Windows7 and “Run <..> as an admin” must be checked off.

Ask us